Important Notices

When upgrading to VidyoPortal™ and VidyoRouter™ version 17.1.0, please refer to the following to ensure that your upgrade goes smoothly:

  • You must upgrade to VidyoPortal and VidyoRouter version 17.1.0 from version 3.4.4 or later. Upgrades from versions earlier than 3.4.4 are not supported. Therefore, if you have a VidyoPortal version that is earlier than 3.4.4, you must first upgrade to 3.4.4 and then upgrade to version 17.1.0.
  • VidyoPortal Virtual Edition version 3.4.x uses more memory in order to run more efficiently than VidyoPortal Virtual Edition version 3.3.x, and therefore requires a minimum of 8 GB of memory. Because previous versions required less memory, you may need to increase the memory allocation on your VidyoPortal Virtual Machine before upgrading.
  • Please review the Upgrade Notices, the Resolved issues in VidyoPortal and VidyoRouter version 17.1.0, and the Known issues in VidyoPortal and VidyoRouter version 17.1.0 articles before upgrading.

What’s New in This Release

Here's what's new in version 17.1.0:

  • Easily select the web SSL/TLS security level that’s right for you
    • You can now update your web SSL/TLS settings quickly and easily using your System Console.
    • We provide three security level settings, so you can choose the one that’s the right fit for your configuration:
      • Modern (TLS 1.2 or Higher): If you don’t need backward compatibility, and only need to be compatible with modern clients (such as Firefox® 27 and later and Chrome™ 30 and later), then this is the option for you. It provides a higher level of security.
      • Intermediate (TLS 1.0 or Higher): Choose this if you need to support a wide range of clients. It provides compatibility with clients as old as Firefox 1, Chrome 1, and Safari® 1.
      • Default (Default Cipher Suite/TLS 1.0 or Higher): You should choose this only if you have legacy clients and need to ensure backward compatibility. This option is compatible with clients all the way back to Windows® XP/IE6.

        SecurityLevels.png

    • For more information, see https://wiki.mozilla.org/Security/Server_Side_TLS#Modern_compatibility and the VidyoConferencing Administrator Guide.
Was this article helpful?
0 out of 0 found this helpful

0 Comments

Follow
Please sign in to leave a comment.