If you are unable to install VidyoDesktop on your Mac OS Sierra, it is probably because you are attempting to use an older version offered by the VidyoPortal your link is associated with.

For Mac OS Sierra compatibility you must use VidyoDesktop 3.6.9 or above.

A current latest version link can be found here.

Was this article helpful?
0 out of 1 found this helpful

0 Comments

Follow
Please sign in to leave a comment.